
1 

ADACX 3.5.0.0 – a tool for creating drawings of public works 
Assets -  Designed or As Constructed. 

August  2010 
 

 
 
 
Background 
 
The ADAC consortium of councils aims to standardise the collection of data about 
Assets – Designed and As Constructed.  Billions of dollars worth of pavements, pipes 
and pits are buried underground and must be managed long into the future.  Councils 
need to collect data on what is down there – where it is, what it’s made of etc.  The 
consultants that design civil infrastructure, and the surveyors who record the finished 
projects ‘as built’ , have this information, but they need a standard format to present 
the information to council. 
 
Although the data will probably end up in an ESRI or MapInfo GIS system, the 
consortium chose the DWG drawing format as a more commonly available medium 
for developers, engineers and surveyors to use.  ADAC DWG drawings contain 
blocks on special layers, with data attributes attached.  The consortium has developed 
AutoCAD VBA macros to help create these attributed blocks.  The consortium also 
defines an XML file format. 
 
Sofoco first learned about the ADAC consortium and AutoCAD-based CAD 
application in November 2006.  At that time, the current version of Bricscad was 
Version 7, based on Intellicad.  Bricscad V7 had a COM API different from 
AutoCAD’s API.  It meant that the published ADAC VBA routines could not run in 
Bricscad.   
 
Councils’  requirement for surveyors and engineers to submit ADAC-standard 
drawings was a threat and an opportunity for Bricscad.  If we couldn’ t support the 
standard, Queensland users would reject Bricscad.  If we could support the standard, a 
Bricscad-based solution would be much cheaper than the AutoCAD alternative and 
could attract new users.  We decided to make an ADAC solution for Bricscad users. 
 
At first, we were unable to obtain the VBA source code, but the consortium was 
happy to supply the ADAC XML schema.  In many ways this was a better starting 
point.  The XML schema defines exactly what information is required and what is 
optional.  It defines the names and allowable values of every item of data.  We based 
our design on the schema. 
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ADACX is really based on the schema 
 
For example, the drop-down lists in our user interface (eg the list of pavement base 
types) are populated directly from the schema definitions.  If a new type is added to 
the schema, it is very little work to rebuild the ADACX application so that it offers 
the new name.  If the property is optional, the list will include an extra entry ‘N/A’ .  
 
When filling in a form, or interpreting the contents of an ADAC block in a drawing, 
everything is filtered through the ADAC schema.  Say there is a Water Valve block in 
the drawing with manufacturer ‘Sofoco’ .  This is not one of the enumerated 
manufacturers allowed by the schema, so this information will be discarded.  The 
default value for this field will be used instead.    
 
ADACX cannot 
read or write 
XML files which 
do not conform to 
the schema.  For 
example, a 
wrongly spelled 
pavement material 
name would be 
rejected. 
 
After we created the initial application, we were given access to the consortium’s 
source code.   Then in July 2007, Bricsys released Bricscad V8 which is much more 
compatible with AutoCAD, and which can run the consortium’s VBA application.  
But we feel the schema-based application is a valuable tool so we’ ll continue to offer 
it, now ported to the ADAC 3.0 standard. 
 
VB and VBA 
 
Visual Basic for Applications is a programming environment available in Bricscad V8 
Pro.  But the Pro version costs a little more than Bricscad V8 Classic.  So ADACX is 
not written using VBA.  Instead it is written as a standalone executable program using 
Visual Basic 2005 (VB.net).  This means that ADACX runs with the cheapest version 
of Bricscad. 
 
It also means it runs alongside Bricscad rather than ‘ in’  Bricscad.  It allows users to 
continue to draw, inquire or measure inside Bricscad while the ADACX dialog is 
displayed on screen.  
 
ADACX for  AutoCAD  
 
ADACX is now compiled in 3 flavours – for Bricscad, ACAD 2009 and ACAD 2010.  
This demonstrates Bricscad as an alternative CAD application platform for software 
developers.   The three executables are built from the exact same source code – not a 
copy, but the same files.  At startup the program discovers which CAD application 
object to use. 
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Installing ADACX: 
Download and unzip the installation file ADACX.zip.  You should have two files 
‘Setup.exe’  and ‘ InstallADACX.msi’ .  Run ‘setup.exe’  and work through the 
installation wizard: 
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The installer will create a sub-folder ‘Blocks’  in the installation folder,  
eg C:\Program Files\Sofoco\ADACX\Blocks.  Inside ADACX, you can select a 
different path to the blocks library, eg if you decide to move it to a network folder (go 
to Settings > Block Path). 
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Launching ADACX in CAD (NEW!) 
 
There are 3 versions of the executable program, typically located in C:\Program Files 
as follows: 
 
C:\Program Files\Sofoco\ADACX 
     \Bricscad\ADACX.exe 
     \ACAD2009\ADACX.exe 
     \ACAD2010\ADACX.exe 
 
There is also a user interface file (ADACX.cui) with a toolbar button that launches 
“ADACX.exe” .  By setting the SRCHPATH variable in CAD, we can get the correct 
executable to run.  Here’s how we do it in Bricscad: 
 
Set ‘SRCHPATH’  
Under Settings>Settings, search for ‘Support File Search Path’ .  We can expand the 
string into a list of paths.  We need to add two paths – one for the ADACX folder, and 
one for the specific CAD system we are running (see Pic) 
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Load the par tial CUI  file ADACX.cui 
From the menu, pick Tools>Customize.  In the Customize dialog, select File >Load 
Partial Cui File.  Browse to the cui file (eg at C:\program 
files\Sofoco\ACADCX\ADACX.cui).  AutoCAD users: Note this is a CUI file, not 
CUIX – in the File Open dialog you may have to change the file extension so it 
displays CUI files. 

 
 
The cui file defines one toolbar with one button.  You can of course add menu items 
or aliases if you prefer.  The command string should be: 
� � � � � � � � � � � 	 
 	 � � 
 � � � � � �
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Running ADACX 
The intent of this program is to tag an existing civil engineering drawing with asset 
information.  The ADACX tool does not really help you to draw eg road geometry.   
Roads, traffic islands and carparks should already exist in the drawing as polylines.  
After tagging, these will be changed to block inserts, with attribute data.  Because 
ADACX changes your drawing, you should make a copy of the base drawing before 
you begin work. 
 
Although it doesn’ t draw roads, ADACX does draw manholes and pipes.  Generally, 
manholes, pits or end structures must be created and identified (numbered) before 
pipes can be drawn.  Then, when creating pipes, the user should click on the upstream 
and downstream manholes to collect their ID’s.  Finally, ADACX draws the pipe 
between the named manholes.  ADACX will be confused if you have multiple pits 
with the same ID. 
 
L icensing 
From version 3.2.0.2 ADACX includes a license manager.  On first startup, the 
program will register itself and allow a 30-day trial period.  After that, a license key 
will be needed to run the program.  
 
Use Help > License to display the license form: 

 
After obtaining a 
license string from 
Sofoco (call or 
email me!), cut and 
paste the string into 
the license key field 
and press ‘Apply’ . 
 
 
 

 
NOTE At Version 3.5  ADACX is now freeware.  The licensing has been disabled.
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ADACX Screens 
Project Information 
 

 
 
This information is required in the schema, but is not stored in drawings.  You should 
fill in this panel just before exporting an XML file.  If you’ re just creating a DWG 
file, you can skip this panel. 
 
Across the top of the ADACX dialog, you can enter the asset owner, council, drawing 
number etc. 
 
The Council code is only important when placing drainage pits.  The code should be 
set to point to your preferred folder of pit inlet blocks.  Some of the DWG blocks used 
to represent drainage pit inlet structures differ between councils, although they may 
have the same basic type information.  ADACX uses the Council code to select an 
appropriate block to represent the inlet. 
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Roads – Pavement 
 

 
 
Road pavements should be represented by a closed polyline.  After filling in the 
various fields, press the button ‘Tag a closed Polyline with this data’ , then select a 
closed polyline.  If you select some other type of drawing entity, Bricscad will prompt 
‘Try Again’ .   
 
‘Save these Settings’ .  This button will save all your settings for this panel.  After this, 
every time you enter the Pavements panel, it will remember your favourite settings. 
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Afterwards, the polyline is turned into a block, and tagged with attribute data.  In 
Bricscad, you can select the block and use the properties bar to verify the attributes 
(see below). 

 
 
Initially, ADACX will remain ‘ linked’  to this pavement block.  You can change any 
of the properties in the ADACX Pavement panel, then press ‘Apply Edits’  to make 
changes.   
 
If you have created a new Pavement object or switched to another tab (panel) in the 
ADACX application, this link is lost.  In that case, you can use the button ‘Edit 
existing ADAC block’  to re-select this pavement for editing. 
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Roads – Parking 
 

 
 
This is very similar to the Pavement panel.  When entering the area of the parking 
object, you can use the “Area m2” button to measure any closed polyline.  You need 
to do this before tagging the polyline, as tagging turns it into a block. 
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Roads – Road Edges 
 

 
 
You should have already created a polyline representing the road edge.  The ‘Length 
m’  button can be used to measure the length of a polyline (Do this before tagging it).  
After setting the type and extension distance, press the ‘Tag a polyline’  button.  Select 
the polyline in your drawing and it will be converted to a block insert with attributes. 
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Roads – Islands 
 

 
 
You should have already created a closed polyline representing the road island.  The 
‘Area m2’  button can be used to measure the area.  After setting the type and infill 
type, press the ‘Tag a Closed Polyline’  button.  Select the polyline in your drawing 
and it will be converted to a block insert with attributes. 
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Roads – Pathway 
 

 
 
You should have already created a polyline representing the pathway.  After filling in 
the details, press the ‘Tag a Polyline’  button.  Select the polyline in your drawing and 
it will be converted to a block insert with attributes. 
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Roads – Pram Ramp 
 

 
 
This tab allows you to place or move a Pram Ramp block. 
 
Use the ‘Set Location’  button to locate the pram ramp.  Bricscad will prompt ‘Locate 
Pram Ramp’ .  Point to the centre of the foot of the ramp (on the kerbline).   
 
Bricscad will prompt ‘Angle of ramp’ .  Point along the kerbline to the left of the ramp  
(ie to the left of a person facing down the ramp).   
 
The coordinates and angle will be displayed in the panel.  You can now adjust the 
coordinates or angle.  In the case of the angle, the up/down arrows allow 90 degree 
increments. 
 
Press ‘Place a Pram Ramp’  to actually insert the ramp block.  If the angle is wrong, 
you can adjust the angle display, then press ‘Apply Edits’  to change it. 
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Roads - Subsoil Drain 
 

 
 
This panel helps us place subsoil drain lines and flush points.  The subsoil drain line 
should have already been created as a polyline.  Press ‘Tag a Polyline’  to select this 
polyline and tag it as a subsoil drain.  Use the ‘Add a Plush Pt button to locate one or 
more flush point symbols to this drain line. 
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Sewer – Manhole 
 

 
 
Use this panel to create Sewer Manhole blocks.   
 
The ‘Chamber Position’  button can be used to locate the position and angle of the 
chamber.  Note: we always prompt for the angle, even for circular manholes.  We 
think this makes the application more consistent, and if you change the shape to 
rectangular, the angle property will be already set.  In the case of drainage manholes, 
some of the extended ‘circular’  types do actually have a long axis direction.  The 
angle can be incremented 90 degrees with the up/down arrow buttons. 
 
After filling in the form (please use a unique manhole number!), press the ‘ Insert’  
button to create the manhole. 
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Sewer – Non-Pressure Pipes 

 
 
To use this panel, you must have already created sewer manholes.  Use the ‘Select’  
button to locate the upstream and downstream manholes for each pipe.  Fill in the 
details for the pipe, then press ‘Create sewer pipe’ .  ADACX will draw the pipe 
between the manholes. 
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Sewer – Pressure Pipe 

 
 
Use this panel to tag a polyline as a sewer pressure pipe or rising main. 
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Sewer – Valve 

 
 
Use the ‘Set location’  button to locate the position and direction of the valve.   Fill in 
the other details, then press ‘Create Valve’ . 
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Sewer – House Connection 

 
 
In this panel, there are many distances to be entered.  The buttons on the panel allow 
us to locate relevant points in the drawing – then Bricscad can calculate the distances 
automatically.  ‘Pick All’  will prompt for the locations of all 5 points in turn. 
 
Note, if you are editing an existing house connection, the distances are calculated 
immediately, but the drawing is only updated after pressing ‘Apply Edits’ .



23 

Sewer – Fitting 

 
 
Use the ‘Set location’  button to locate the position and direction of the fitting.   Fill in 
the other details, then press ‘Create Fitting’ . 
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Drains – Manhole Pit 

 
 
This is a complex panel.  Two locations (position and angle) are stored – one for the 
centre of the chamber, and one for the inlet structure.  The Pit number must be unique 
so that ADACX can find this pit when attaching pipes. 
 
When the ‘Use’  field is changed to ‘Pit’ , additional controls are displayed for defining 
the inlet structure.   
 
Note: ADACX only records the information specified in the ADAC XML schema, ie 
the information that will be available in an ADAC XML file.  This doesn’ t include the 
name of the DWG block used to represent the inlet structure.  Instead, ADACX infers 
the most appropriate block to use from the other properties given.  We have to work 
this way to be able to import an ADAC XML file and create a drawing from it. 
 
If the inlet type could have a lintel, then the lintel type and length controls are 
displayed, but for field inlets, these controls are hidden. 
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Drains – End Structure 

 
 
As for Manhole/Pits, End Structures must be given a unique number so that ADACX 
can connect the pipes. 
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Drains – Pipes 

 
 
Upstream and downstream pipe ends can be located by selecting an existing ADAC 
Manhole/Pit or End Structure.  Use the ‘Select Object’  buttons to locate a pit or 
structure and automatically pick up the Pit number and location.  Alternatively, we 
can just locate a point in space using the ‘Locate Point’  buttons.   
 
Once the two end points and IL’s are defined, ADACX will compute the length and 
grade.  Press ‘ Insert Pipe’  to create the pipe block. 
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Drains – Surface Drainage 

 
 
Use this panel to tag a polyline in the drawing as a surface drainage channel. 
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Water  – Pipe 

 
 
Use this tab to tag a polyline as a water pipe.  Before tagging the pipe, you can use the 
‘Pipe Length’  button to select the polyline and measure its length. 
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Water  Valves, Hydrants, Meters, Fittings 

 
 
These panels all work the same way.  Fill in the details and use the ‘Set location’  
button to record the position of the asset.  Then use the ‘Create button to insert the 
appropriate block with attributes.  
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Water  – Maintenance Hole 

 
 
This panel allows us to create a block representing a water supply manhole.  First use 
the ‘Chamber Pos.’  button to locate the manhole, fill in the other details, then press 
‘Create Maintenance Hole’  to insert the block. 
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Cadastre – Land Parcel 

 
 
Use this tab to select a close polyline and tag it as a land parcel.  Before tagging the 
polyline, the ‘Area’  button can be used to select it and measure its area. 
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Pulldown Menus 
File > Impor t XML 
 
This command will import an ADAC XML file (ie an XML file created according to 
the ADAC 3.0 schema).  In Bricscad, we should open a new empty drawing file 
before selecting this command.  ADACX will draw the ADAC blocks into the active 
drawing.   
 
After selecting this command, ADACX will display the File Open dialog, allowing us 
to browse to an XML file to read.  After selecting a file to read, ADACX will open 
the file and work through the objects described in the file, creating DWG Block 
inserts and attaching the needed attribute data. 
 
As soon as ADACX begins reading the file, it is OK to use viewing commands in 
Bricscad, eg to Zoom Extents.  That way we can watch the drawing being created.  
Don’ t try to draw anything or switch to a different drawing while ADACX is drawing. 
 
File > Export visible layers to XML 
 
This command finds all the ADAC blocks on visible layers and writes them out to an 
ADAC XML file.  By switch off layers in the drawing you could create an XML file 
of just the drainage or just the cadastre etc.  Make sure to use the Project Tab to fill 
out the Project header for this file. 
 
File > Rebuild all ADAC blocks (expor t-impor t) 
 
This option rebuilds the drawing by exporting all ADAC blocks to their XML 
equivalent and re-importing them.  This is really just for testing, but it can be used to 
re-create all the blocks, eg if you have changed some settings such as the attribute 
visibility. 
 
File > Exit  
 
This closes the ADACX application. 
 
Settings > Block Path 
 
At installation, the ADAC DWG blocks representing valves, drainage pit inlets etc 
will be stored at C:\program files\Sofoco\Adacx\Blocks.  You can use this option to 
point to some other folder.  If you copy the blocks to another folder, eg on a network 
drive, be sure to copy the whole folder tree under ‘blocks’ .  The program will become 
unstable if it tries to insert a block by name and cannot find it. 
 
Settings > Solid Fill 
 
This just toggles the Bricscad system variable ‘Fillmode’ .  With solid fill on, pipes 
will appear as solid rectangles of colour.  With solid fill off, they will be drawn as 
outlines. 
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Settings > Attr ibute Styles 
 
This launches a long list of ‘Attribute Styles’  used to control the appearance of the 
block attributes in the drawing.   

 
 
Each ADAC attribute is identified by: module (eg ‘Roads’ ), panel (eg ‘Pavement’ ), 
and attribute name (eg ‘StreetName).  For each attribute, we store: Visibility (it will 
be displayed in the drawing or not), Height in m (modelspace units), and Italic (yes or 
no).  You can adjust these settings to your preference.  When ADACX is importing an 
XML file to create a drawing, it will use these attribute settings. 
 
The last column displays the default value for each attribute.  This information is 
defined by filling in the appropriate panel (eg the Road Pavement panel) and pressing 
the ‘Save these Settings’  button on that panel.  Then whenever you switch back to that 
panel, eg to create a new Pavement object, your favourite settings will be already 
filled in. 
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Tools > Attr ibute Visibility 
 
This option allows us to 
switch on or off the 
attributes attached to a 
block.  To use this, first 
we should press ‘Edit 
existing ADAC block’  
and select something, 
eg a Road Pavement.  
 
The Pavement panel 
will open and display 
the properties 
(attributes) of this 
block.  At this stage, we 
may want to display 
more of the attribute 
information in the 
drawing.   
 
Let’s say we want the 
StreetName to be 
displayed:  Select 
‘Tools > Attr ibute 
Visibility’ .  The 
attributes of this block 
will be listed in the 
Attribute Visibility 
dialog.  Use the 
checkboxes to switch 
attributes on or off. 
 
Press ‘Apply’  to make the change to this block.  Press ‘Apply to All’ , eg to switch on 
the StreetName for all pavement objects. 
 
Note this is provided as a local override to the more general Attribute Styles tool 
described above. 
 
Tools > Move Attr ibutes 
 
To use this, first we should press ‘Edit existing ADAC block’  and select something, 
eg a Road Pavement.   Then Select Tools > Move Attributes.  You are prompted for a 
new position for the attribute texts in the drawing. 
 
Note, if you rebuild this block later (ie by pressing ‘Apply Edits’ ) the attribute texts 
will jump back to their original position.  This happens because ADACX creates an 
XML ‘schema object’  from the information in the form, then uses that schema object 
to draw the Bricscad block.  The ADAC XML schema doesn’ t define any information 
about attribute text positions, therefore the text position is always reset. 
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Tools > Rotate Attr ibutes 
 
To use this, first we should press ‘Edit existing ADAC block’  and select something, 
eg a Road Pavement.   Then Select Tools > Rotate Attributes.  You are prompted for a 
new angle for the attribute texts in the drawing. 
 
Note, if you rebuild this block later (ie by pressing ‘Apply Edits’ ) the attribute texts 
will jump back to their original position.  This happens because ADACX creates an 
XML ‘schema object’  from the information in the form, then uses that schema object 
to draw the Bricscad block.  The ADAC XML schema doesn’ t define any information 
about attribute text positions, therefore the text position is always reset. 
 
Help > About 
 
The AboutBox displays the application version and copyright notice. 
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